requirements.txt 2.87 KB
Newer Older
1
2
3
4
#
# This file is autogenerated by pip-compile
# To update, run:
#
5
#    pip-compile
6
#
7
8
9
attrs==20.3.0
    # via jsonschema
certifi==2020.12.5
10
    # via requests
11
chardet==4.0.0
12
13
14
15
16
17
18
19
20
21
22
    # via
    #   frictionless
    #   requests
click==7.1.2
    # via
    #   flask
    #   opendataschema
    #   typer
colorama==0.4.4
    # via typer
commonmark==0.9.1
23
    # via validata_ui (setup.py)
24
25
decorator==4.4.2
    # via validators
26
deprecated==1.2.11
27
    # via pygithub
28
29
et-xmlfile==1.0.1
    # via openpyxl
30
ezodf==0.3.2
31
32
33
    # via
    #   validata-core
    #   validata_ui (setup.py)
34
flask==1.1.2
35
    # via validata_ui (setup.py)
Pierre Dittgen's avatar
Pierre Dittgen committed
36
frictionless==4.0.12
37
38
39
    # via
    #   validata-core
    #   validata_ui (setup.py)
40
41
idna==2.10
    # via requests
Pierre Dittgen's avatar
Pierre Dittgen committed
42
importlib-resources==5.1.1
43
    # via validata-core
44
45
46
47
isodate==0.6.0
    # via frictionless
itsdangerous==1.1.0
    # via flask
48
49
jdcal==1.4.1
    # via openpyxl
50
jinja2==2.11.3
51
52
53
54
55
56
    # via flask
jsonschema==3.2.0
    # via
    #   frictionless
    #   opendataschema
lxml==4.6.2
57
58
59
    # via
    #   validata-core
    #   validata_ui (setup.py)
60
61
markupsafe==1.1.1
    # via jinja2
62
numpy==1.20.1
63
    # via pandas
64
65
opendataschema==0.6.0
    # via validata_ui (setup.py)
66
67
openpyxl==3.0.6
    # via validata-core
Pierre Dittgen's avatar
Pierre Dittgen committed
68
pandas==1.2.3
69
    # via tablib
70
petl==1.7.2
71
    # via frictionless
Pierre Dittgen's avatar
Pierre Dittgen committed
72
pydantic==1.8.1
73
    # via validata_ui (setup.py)
74
pygithub==1.54.1
75
76
77
78
79
80
    # via opendataschema
pyjwt==1.7.1
    # via pygithub
pyrsistent==0.17.3
    # via jsonschema
python-dateutil==2.8.1
81
82
83
    # via
    #   frictionless
    #   pandas
84
python-dotenv==0.15.0
85
    # via validata_ui (setup.py)
86
python-gitlab==2.6.0
87
88
89
    # via opendataschema
python-slugify==4.0.1
    # via frictionless
90
python-stdnum==1.16
91
    # via validata-core
92
pytz==2021.1
93
94
    # via pandas
pyyaml==5.4.1
95
96
    # via
    #   frictionless
97
    #   validata_ui (setup.py)
98
requests-cache==0.5.2
99
    # via validata_ui (setup.py)
100
101
requests-toolbelt==0.9.1
    # via python-gitlab
102
requests==2.25.1
103
104
105
106
107
108
    # via
    #   frictionless
    #   opendataschema
    #   pygithub
    #   python-gitlab
    #   requests-cache
109
    #   requests-toolbelt
110
111
    #   validata-core
    #   validata_ui (setup.py)
Pierre Dittgen's avatar
Pierre Dittgen committed
112
113
rfc3986==1.4.0
    # via frictionless
114
shellingham==1.4.0
115
116
117
118
119
120
121
122
123
124
125
    # via typer
simpleeval==0.9.10
    # via frictionless
six==1.15.0
    # via
    #   isodate
    #   jsonschema
    #   python-dateutil
    #   validators
stringcase==1.2.0
    # via frictionless
126
127
tablib[pandas]==3.0.0
    # via validata-core
128
129
130
text-unidecode==1.3
    # via python-slugify
toml==0.10.2
131
    # via validata_ui (setup.py)
132
133
toolz==0.11.1
    # via validata-core
134
135
typer[all]==0.3.2
    # via frictionless
Pierre Dittgen's avatar
Pierre Dittgen committed
136
137
typing-extensions==3.7.4.3
    # via pydantic
138
urllib3==1.26.3
139
    # via requests
Pierre Dittgen's avatar
Pierre Dittgen committed
140
validata-core==0.7.0a1
141
    # via validata_ui (setup.py)
142
validators==0.18.2
143
144
145
146
147
    # via frictionless
werkzeug==1.0.1
    # via flask
wrapt==1.12.1
    # via deprecated
148
149
150

# The following packages are considered to be unsafe in a requirements file:
# setuptools