Commit 23920f5a authored by Pierre Dittgen's avatar Pierre Dittgen

Using pip-compile to freeze dependencies

parent ebaaf098
backports-datetime-fromisoformat==1.0.0
cachecontrol==0.12.5
commonmark==0.8.1
ezodf==0.3.2
Flask==1.0.2
lxml==4.2.5
opendataschema==0.5.5
python-dotenv==0.10.1
requests==2.22.0
toml==0.10.0
tabulator==1.21.0
validata_core==0.5.4
#
# This file is autogenerated by pip-compile
# To update, run:
#
# pip-compile
#
attrs==19.3.0 # via jsonschema
backports-datetime-fromisoformat==1.0.0 # via validata_ui (setup.py)
boto3==1.12.35 # via tabulator
botocore==1.15.35 # via boto3, s3transfer
cachecontrol==0.12.6 # via validata_ui (setup.py)
certifi==2019.11.28 # via requests
chardet==3.0.4 # via datapackage, requests, tabulator
click-default-group==1.2.2 # via goodtables
click==7.1.1 # via click-default-group, datapackage, flask, goodtables, opendataschema, tableschema, tabulator
commonmark==0.9.1 # via validata_ui (setup.py)
datapackage==1.13.0 # via goodtables
deprecated==1.2.7 # via pygithub
docutils==0.15.2 # via botocore, statistics
et-xmlfile==1.0.1 # via openpyxl
ezodf==0.3.2 # via validata-core, validata_ui (setup.py)
flask==1.1.1 # via validata_ui (setup.py)
goodtables==2.4.12 # via validata-core
idna==2.9 # via requests
ijson==3.0 # via tabulator
importlib-metadata==1.6.0 # via importlib-resources, jsonschema
importlib-resources==1.4.0 # via validata-core
isodate==0.6.0 # via tableschema
itsdangerous==1.1.0 # via flask
jdcal==1.4.1 # via openpyxl
jinja2==2.11.1 # via flask
jmespath==0.9.5 # via boto3, botocore
jsonlines==1.2.0 # via tabulator
jsonpointer==2.0 # via datapackage
jsonschema==3.2.0 # via datapackage, opendataschema, tableschema
linear-tsv==1.1.0 # via tabulator
lxml==4.5.0 # via validata-core, validata_ui (setup.py)
markupsafe==1.1.1 # via jinja2
msgpack==1.0.0 # via cachecontrol
numpy==1.18.2 # via pandas
opendataschema==0.5.5 # via validata_ui (setup.py)
openpyxl==3.0.3 # via tabulator
pandas==1.0.3 # via tablib
pygithub==1.47 # via opendataschema
pyjwt==1.7.1 # via pygithub
pyrsistent==0.16.0 # via jsonschema
python-dateutil==2.8.1 # via botocore, pandas, tableschema
python-dotenv==0.12.0 # via validata_ui (setup.py)
python-gitlab==2.1.2 # via opendataschema
python-stdnum==1.13 # via validata-core
pytz==2019.3 # via pandas
requests==2.23.0 # via cachecontrol, datapackage, goodtables, opendataschema, pygithub, python-gitlab, tableschema, tabulator, validata-core, validata_ui (setup.py)
rfc3986==1.3.2 # via tableschema
s3transfer==0.3.3 # via boto3
simpleeval==0.9.10 # via goodtables
six==1.14.0 # via datapackage, goodtables, isodate, jsonlines, jsonschema, linear-tsv, pyrsistent, python-dateutil, tableschema, tabulator
sqlalchemy==1.3.15 # via tabulator
statistics==1.0.3.5 # via goodtables
tableschema==1.12.4 # via datapackage, goodtables, validata-core
tablib[pandas]==1.1.0 # via validata-core
tabulator==1.38.1 # via datapackage, goodtables, tableschema, validata-core, validata_ui (setup.py)
toml==0.10.0 # via validata_ui (setup.py)
toolz==0.10.0 # via validata-core
unicodecsv==0.14.1 # via datapackage, tableschema, tabulator
urllib3==1.25.8 # via botocore, requests
validata-core==0.5.6 # via validata_ui (setup.py)
werkzeug==1.0.1 # via flask
wrapt==1.12.1 # via deprecated
xlrd==1.2.0 # via tabulator
zipp==3.1.0 # via importlib-metadata, importlib-resources
# The following packages are considered to be unsafe in a requirements file:
# setuptools
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment