Commit caed9d5b authored by Christophe Benz's avatar Christophe Benz
Browse files

Add validata_core dependency, move them to requirements.in

parent 5b1c8fcd
......@@ -3,6 +3,7 @@ validata_ui.egg-info/
.env
.vscode/
homepage_config.json
src/
# Cypress ui tests
screenshotsFolder
......
-e git+https://git.opendatafrance.net/validata/validata-core.git@frictionless_py_migration#egg=validata_core
backports-datetime-fromisoformat
cachecontrol
commonmark
ezodf
flask
frictionless >= 3.39.0
lxml
python-dotenv
requests
sentry-sdk[flask] == 0.14.3
toml
opendataschema >= 0.5.5, < 0.6
validata_core >= 0.6.0a0
......@@ -4,52 +4,62 @@
#
# pip-compile
#
-e git+https://git.opendatafrance.net/validata/validata-core.git@frictionless_py_migration#egg=validata_core # via -r requirements.in
attrs==20.3.0 # via jsonschema
backports-datetime-fromisoformat==1.0.0 # via -r requirements.in
blinker==1.4 # via sentry-sdk
cachecontrol==0.12.6 # via validata_ui (setup.py)
certifi==2020.11.8 # via requests, sentry-sdk
cachecontrol==0.12.6 # via -r requirements.in
certifi==2020.12.5 # via requests, sentry-sdk
chardet==3.0.4 # via frictionless, requests
click==7.1.2 # via flask, opendataschema, typer
colorama==0.4.4 # via typer
commonmark==0.9.1 # via validata_ui (setup.py)
commonmark==0.9.1 # via -r requirements.in
decorator==4.4.2 # via validators
deprecated==1.2.10 # via pygithub
ezodf==0.3.2 # via validata_ui (setup.py)
flask==1.1.2 # via sentry-sdk, validata_ui (setup.py)
frictionless==3.37.0 # via validata_ui (setup.py)
et-xmlfile==1.0.1 # via openpyxl
ezodf==0.3.2 # via -r requirements.in, validata-core
flask==1.1.2 # via -r requirements.in, sentry-sdk
frictionless==3.46.0 # via -r requirements.in, validata-core
idna==2.10 # via requests
importlib-metadata==3.1.0 # via jsonschema
importlib-resources==3.3.0 # via validata-core
isodate==0.6.0 # via frictionless
itsdangerous==1.1.0 # via flask
jdcal==1.4.1 # via openpyxl
jinja2==2.11.2 # via flask
jsonschema==3.2.0 # via frictionless, opendataschema
lxml==4.6.2 # via validata_ui (setup.py)
lxml==4.6.2 # via -r requirements.in, validata-core
markupsafe==1.1.1 # via jinja2
msgpack==1.0.0 # via cachecontrol
opendataschema==0.5.5 # via validata_ui (setup.py)
msgpack==1.0.2 # via cachecontrol
numpy==1.19.4 # via pandas
opendataschema==0.5.5 # via -r requirements.in
openpyxl==3.0.5 # via validata-core
pandas==1.1.5 # via tablib
petl==1.6.8 # via frictionless
pygithub==1.54 # via opendataschema
pyjwt==1.7.1 # via pygithub
pyrsistent==0.17.3 # via jsonschema
python-dateutil==2.8.1 # via frictionless
python-dotenv==0.15.0 # via validata_ui (setup.py)
python-dateutil==2.8.1 # via frictionless, pandas
python-dotenv==0.15.0 # via -r requirements.in
python-gitlab==2.5.0 # via opendataschema
python-slugify==4.0.1 # via frictionless
python-stdnum==1.14 # via validata-core
pytz==2020.4 # via pandas
pyyaml==5.3.1 # via frictionless
requests==2.24.0 # via cachecontrol, frictionless, opendataschema, pygithub, python-gitlab, validata_ui (setup.py)
sentry-sdk[flask]==0.14.3 # via validata_ui (setup.py)
requests==2.24.0 # via -r requirements.in, cachecontrol, frictionless, opendataschema, pygithub, python-gitlab, validata-core
sentry-sdk[flask]==0.14.3 # via -r requirements.in
shellingham==1.3.2 # via typer
simpleeval==0.9.10 # via frictionless
six==1.15.0 # via isodate, jsonschema, python-dateutil, validators
stringcase==1.2.0 # via frictionless
tablib[pandas]==3.0.0 # via validata-core
text-unidecode==1.3 # via python-slugify
toml==0.10.2 # via validata_ui (setup.py)
toml==0.10.2 # via -r requirements.in
toolz==0.11.1 # via validata-core
typer[all]==0.3.2 # via frictionless
urllib3==1.25.11 # via requests, sentry-sdk
validators==0.18.1 # via frictionless
werkzeug==1.0.1 # via flask
wrapt==1.12.1 # via deprecated
zipp==3.4.0 # via importlib-metadata
# The following packages are considered to be unsafe in a requirements file:
# setuptools
......@@ -42,17 +42,4 @@ setup(
include_package_data=True,
package_data={"validata_ui": ["templates/*", "static/**/*"],},
zip_safe=True,
install_requires=[
"backports-datetime-fromisoformat",
"cachecontrol",
"commonmark",
"ezodf",
"flask",
"lxml",
"python-dotenv",
"requests",
"sentry-sdk[flask]==0.14.3",
"toml",
"opendataschema >= 0.5.5, < 0.6",
],
)
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment