Commit d16b8add authored by Pierre Dittgen's avatar Pierre Dittgen
Browse files

Update python-gitlab version via opendataschema upgrade

parent e8c2d65d
......@@ -4,72 +4,199 @@
#
# pip-compile
#
attrs==19.3.0 # via jsonschema
backports-datetime-fromisoformat==1.0.0 # via validata_ui (setup.py)
blinker==1.4 # via sentry-sdk
boto3==1.12.36 # via tabulator
botocore==1.15.36 # via boto3, s3transfer
cachecontrol==0.12.6 # via validata_ui (setup.py)
certifi==2020.4.5.1 # via requests, sentry-sdk
chardet==3.0.4 # via datapackage, requests, tabulator
click-default-group==1.2.2 # via goodtables
click==7.1.1 # via click-default-group, datapackage, flask, goodtables, opendataschema, tableschema, tabulator
commonmark==0.9.1 # via validata_ui (setup.py)
datapackage==1.13.0 # via goodtables
deprecated==1.2.8 # via pygithub
docutils==0.15.2 # via botocore, statistics
et-xmlfile==1.0.1 # via openpyxl
ezodf==0.3.2 # via validata-core, validata_ui (setup.py)
flask==1.1.2 # via sentry-sdk, validata_ui (setup.py)
goodtables==2.4.12 # via validata-core
idna==2.9 # via requests
ijson==3.0 # via tabulator
importlib-metadata==1.6.0 # via importlib-resources, jsonschema
importlib-resources==1.4.0 # via validata-core
isodate==0.6.0 # via tableschema
itsdangerous==1.1.0 # via flask
jdcal==1.4.1 # via openpyxl
jinja2==2.11.1 # via flask
jmespath==0.9.5 # via boto3, botocore
jsonlines==1.2.0 # via tabulator
jsonpointer==2.0 # via datapackage
jsonschema==3.2.0 # via datapackage, opendataschema, tableschema
linear-tsv==1.1.0 # via tabulator
lxml==4.5.0 # via validata-core, validata_ui (setup.py)
markupsafe==1.1.1 # via jinja2
msgpack==1.0.0 # via cachecontrol
numpy==1.18.2 # via pandas
opendataschema==0.5.5 # via validata_ui (setup.py)
openpyxl==3.0.3 # via tabulator
pandas==1.0.3 # via tablib
pygithub==1.47 # via opendataschema
pyjwt==1.7.1 # via pygithub
pyrsistent==0.16.0 # via jsonschema
python-dateutil==2.8.1 # via botocore, pandas, tableschema
python-dotenv==0.12.0 # via validata_ui (setup.py)
python-gitlab==2.1.2 # via opendataschema
python-stdnum==1.13 # via validata-core
pytz==2019.3 # via pandas
requests==2.23.0 # via cachecontrol, datapackage, goodtables, opendataschema, pygithub, python-gitlab, tableschema, tabulator, validata-core, validata_ui (setup.py)
rfc3986==1.3.2 # via tableschema
s3transfer==0.3.3 # via boto3
sentry-sdk[flask]==0.14.3 # via validata_ui (setup.py)
simpleeval==0.9.10 # via goodtables
six==1.14.0 # via datapackage, goodtables, isodate, jsonlines, jsonschema, linear-tsv, pyrsistent, python-dateutil, tableschema, tabulator
sqlalchemy==1.3.15 # via tabulator
statistics==1.0.3.5 # via goodtables
tableschema==1.15.3 # via datapackage, goodtables, validata-core
tablib[pandas]==1.1.0 # via validata-core
tabulator==1.38.1 # via datapackage, goodtables, tableschema, validata-core, validata_ui (setup.py)
toml==0.10.0 # via validata_ui (setup.py)
toolz==0.10.0 # via validata-core
unicodecsv==0.14.1 # via datapackage, tableschema, tabulator
urllib3==1.25.8 # via botocore, requests, sentry-sdk
validata-core==0.5.7 # via validata_ui (setup.py)
werkzeug==1.0.1 # via flask
wrapt==1.12.1 # via deprecated
xlrd==1.2.0 # via tabulator
zipp==3.1.0 # via importlib-metadata, importlib-resources
attrs==20.3.0
# via jsonschema
backports-datetime-fromisoformat==1.0.0
# via validata_ui (setup.py)
blinker==1.4
# via sentry-sdk
boto3==1.17.15
# via tabulator
botocore==1.20.15
# via
# boto3
# s3transfer
cachecontrol==0.12.6
# via validata_ui (setup.py)
cached-property==1.5.2
# via tableschema
certifi==2020.12.5
# via
# requests
# sentry-sdk
chardet==4.0.0
# via
# datapackage
# requests
# tabulator
click-default-group==1.2.2
# via goodtables
click==7.1.2
# via
# click-default-group
# datapackage
# flask
# goodtables
# opendataschema
# tableschema
# tabulator
commonmark==0.9.1
# via validata_ui (setup.py)
datapackage==1.15.2
# via goodtables
deprecated==1.2.11
# via pygithub
docutils==0.16
# via statistics
et-xmlfile==1.0.1
# via openpyxl
ezodf==0.3.2
# via
# validata-core
# validata_ui (setup.py)
flask==1.1.2
# via
# sentry-sdk
# validata_ui (setup.py)
goodtables==2.5.4
# via validata-core
idna==2.10
# via requests
ijson==3.1.3
# via tabulator
importlib-resources==5.1.0
# via validata-core
isodate==0.6.0
# via tableschema
itsdangerous==1.1.0
# via flask
jdcal==1.4.1
# via openpyxl
jinja2==2.11.3
# via flask
jmespath==0.10.0
# via
# boto3
# botocore
jsonlines==2.0.0
# via tabulator
jsonpointer==2.0
# via datapackage
jsonschema==3.2.0
# via
# datapackage
# opendataschema
# tableschema
linear-tsv==1.1.0
# via tabulator
lxml==4.6.2
# via
# validata-core
# validata_ui (setup.py)
markupsafe==1.1.1
# via jinja2
msgpack==1.0.2
# via cachecontrol
numpy==1.20.1
# via pandas
opendataschema==0.6.0
# via validata_ui (setup.py)
openpyxl==3.0.6
# via tabulator
pandas==1.2.2
# via tablib
pygithub==1.54.1
# via opendataschema
pyjwt==1.7.1
# via pygithub
pyrsistent==0.17.3
# via jsonschema
python-dateutil==2.8.1
# via
# botocore
# pandas
# tableschema
python-dotenv==0.15.0
# via validata_ui (setup.py)
python-gitlab==2.6.0
# via opendataschema
python-stdnum==1.16
# via validata-core
pytz==2021.1
# via pandas
requests-toolbelt==0.9.1
# via python-gitlab
requests==2.25.1
# via
# cachecontrol
# datapackage
# goodtables
# opendataschema
# pygithub
# python-gitlab
# requests-toolbelt
# tableschema
# tabulator
# validata-core
# validata_ui (setup.py)
rfc3986==1.4.0
# via tableschema
s3transfer==0.3.4
# via boto3
sentry-sdk[flask]==0.14.3
# via validata_ui (setup.py)
simpleeval==0.9.10
# via goodtables
six==1.15.0
# via
# datapackage
# goodtables
# isodate
# jsonschema
# linear-tsv
# python-dateutil
# tableschema
# tabulator
sqlalchemy==1.3.23
# via tabulator
statistics==1.0.3.5
# via goodtables
tableschema==1.20.2
# via
# datapackage
# goodtables
# validata-core
tablib[pandas]==3.0.0
# via validata-core
tabulator==1.53.4
# via
# datapackage
# goodtables
# tableschema
# validata-core
# validata_ui (setup.py)
toml==0.10.2
# via validata_ui (setup.py)
toolz==0.11.1
# via validata-core
unicodecsv==0.14.1
# via
# datapackage
# tableschema
# tabulator
urllib3==1.26.3
# via
# botocore
# requests
# sentry-sdk
validata-core==0.5.7
# via validata_ui (setup.py)
werkzeug==1.0.1
# via flask
wrapt==1.12.1
# via deprecated
xlrd==2.0.1
# via tabulator
# The following packages are considered to be unsafe in a requirements file:
# setuptools
......@@ -70,7 +70,7 @@ setup(
'tabulator',
'opendataschema >= 0.5.5, < 0.6',
'opendataschema >= 0.6',
'validata_core >= 0.5.0, < 0.6',
],
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment